理解并配置:IPv6的OSPFv3

理解并配置IPv6OSPFv3

   OSPFv3主要用于在IPv6网络中提供路由功能,OSPFv3是基于OSPFv2上开发用于IPv6网络的路由协议。而无论是OSPFv2还是OSPFv3在工作机制上基本相同;但为了支持IPv6地址格式,OSPFv3对OSPFv2做了一些改动,下面将介绍OSPFv3与OSPFv2的异同点。

OSPFv3与OSPFv2类似也使用组播进行工作,OSPFv3的DR路由器使用众所周知的IPv6组播地址FF02::6这个地址,它类似于IPv4环境中的224.0.0.6;其他的OSPFv3的路由器使用FF02::5这个组播地址,它类似于IPv4环境中的224.0.0.5

OSPFv3OSPFv2相同点:

OSPFv3协议设计思路和工作机制与OSPFv2基本一致,相同点如下所示:

n数据包类型相同:其中包括Hello、DBD(数据库描述)、LSR(链路状态请求)、LSU(链路状态更新)和LSAck(链路状态确定包)。

n区域划分相同包括骨干区域、一般区域、末节区域、NSSA(次末节区域)和完全末节区域。

n路由器类型相同:包括内部路由器(internalrouter)、骨干路由器(backbone router)、区域边界路由器(area border router)和自治系统边界路由器(autonomoussystem boundary router)。

n使用网络类型相同:包括点到点络网、点到多点网络、多路访问网络、NBMA网络。

n邻居发现和邻接关系形成机制相同:OSPF 路由器启动后,便会通过 OSPF接口向外发送 Hello报文,收到 Hello报文的 OSPF路由器会检查报文中所定义的参数,如果双方一致就会形成邻居关系。

nLSA洪和同步机制相同:为了保证 LSDB内容的正确性,需要保证 LSA的可靠泛洪和同步。

nDR选举机制相同:在 NBMA网络和广播网络中DR和BDR的选举过程相同。

n路由计算方法相同:采用最短路径优先算法(SPF)计算路由。

OSPFv3OSPFv2不同点

为适应IPv6运行环境,支持IPv6报文的转发,OSPFv3相对OSPFv2做出相关的改进,使得OSPFv3可以独立于网络层协议,并且其扩展性加强,可以满足未来的需求。其与OSPFv2不同点如下所示:

n基于链路的运行

n使用IPv6链路本地地址

n链路支持多实例复用

n通过RouterID唯一标识邻居

n认证的变化

nOPSFv3更灵活的处理未知LSA类型

nOSPFv3增加了本地链路洪泛扩散的范围

nOSPFv3取消了寻址的概念

理解基于链路的运行:

OSPFv2是基于网络运行的,也就是说两台路由器要形成邻居关系,它们必须在同一个子网。OSPFv3是基于链路运行的,一个链路可以划分为多个IPv6前缀(类似于子网的概念),节点即使不在同一个前缀范围,只要在同一链路上也可以形成邻居关系,这与OSPFv2完全不同,因为在IPv6中一条链路可以属于多个子网。

理解使用IPv6链路本地地址:

OSPFv3将使用本地链路地址作为报文发送的源地址。一台路由器可以学习到同一链路上相连的所有路由器的本地链路地址,并使用这些本地链路地址作为下一跳来转发报文。但是在虚拟链路连接上,必须使用全球范围地址或者本地站点地址作为OSPFv3协议报文发送的源地址。本地链路地址只在本地链路上有意义且只能在本地链路上泛洪。

理解链路支持多实例复用:

理解并配置:IPv6的OSPFv3

理解通过Router ID唯一标识邻居:

   在OPSFv2中,当OSPF运行在广播网络或者NBMA网络上时,OSPFv2的邻居是通过路由器的接口地址进行标识,而其他链路的 OSPFv2的邻居则是通过路由器ID(RID)来表示。在OSPFv3中取消了这种不一致性,所有类型的链路全部通过RID来标识邻居,而且OPSFv3的RID将会作为配置的必须项,在OPSFv2中RID的配置是可选项,在OSPFv3中如果不为路由器配置RID那么OSPFv3将无法启动,会出现如图12.122所示的提示:

理解并配置:IPv6的OSPFv3

理解认证的变化:

在OSPFv2中OSPF拥有自己特有的认证方式,这些认证消息被包含在OSPFv2的数据包中。OSPFv3自身不再提供认证功能,而是通过使用IPv6提供的安全机制来保证自身报文的合法性。所以,OSPFv2报文中的认证字段,在OSPFv3报文头中被取消。

理解OPSFv3更灵活的处理未知LSA类型:

在OSPFv2上会对未知的LSA作丢弃,在OSPFv3中可以把这些未知的LSA当作本地链路洪泛扩散范围,这类似于这些未知的LSA被识别一样,但是在它们自己的SPF算法中将被忽略,这样做的结果是OSPFv3处理网络的变化比v2更容易。

理解OSPFv3增加了本地链路洪泛扩散的范围:

因为IPv6的本地链路地址有广泛的用途,所以OSPFv3增加了一个本地链路洪泛扩散的范围,新增加的LSA叫做链路LSA,它用来携带单个链路上邻居相关联的信息,这种类型的LSA只在本地链路范围内洪泛,所以它不能超出路由器以外进行扩散。

理解OSPFv3取消了寻址的概念:

OSPFv3的路由器LSA和网络LSA不再携带IP地址,这加强了OSPF的扩展性。

演示:在IPv6环境中OSPFv3的配置

演示目标:配置IPv6环境中的路由协议OSPFv3。

演示环境:如图12.123所示。

理解并配置:IPv6的OSPFv3


演示背景:分别在路由器R1、R2、R3上配置三个环回接口,分别配置三个全球单播范围内的IPv6地址,模拟三个不同的IPv6前缀(类似于IPv4的子网),然后在三台路由器上启动OSPFv3,最后来观察IPv6的路由学习结果,查看OSPFv3的邻居关系等。

演示步骤:

第一步:首先完成路由器R1R2R3Ipv6的基础配置,其中包括启动IPv6和配置IPv6的接口地址,激活接口,具体配置如下:

路由器R1的基础配置:

R1(config)#ipv6 unicast-routing* 启动IPv6路由功能

R1(config)#interface e1/0* 进入E1/0接口模式

R1(config-if)#ipv6 enable* 在接口下启动IPv6,将自动生成本地链路地址

R1(config-if)#no shutdown* 激活该接口

R1(config-if)#exit

R1(config)#interface loopback1

R1(config-if)#ipv6 address 2001:1::1/64

路由器R2的基础配置:

R2(config)#ipv6 unicast-routing

R2(config)#interface e1/0

R2(config-if)#ipv6 enable

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#interface loopback1

R2(config-if)#ipv6 address 2001:2::1/64

路由器R3的基础配置:

R3(config)#ipv6 unicast-routing

R3(config)#interface e1/0

R3(config-if)#ipv6 enable

R3(config-if)#no shutdown

R3(config-if)#exit

R3(config)#interface loopback1

R3(config-if)#ipv6 address 2001:3::1/64

第二步:现在开始在完成基础配置的基础上,在各个路由器上启动OSPFv3路由协议,具体配置如下所示:

在路由器R3的OSPFv3配置:

R3(config)#ipv6 router ospf 1* 启动OSPFv3的路由进程

R3(config-rtr)#router-id 3.3.3.3* 为OSPFv3配置路由器ID(RID)

R3(config-rtr)#exit* 退出OSPFv3的路由配置模式

R3(config)#interface e1/0* 进入E1/0接口模块

R3(config-if)#ipv6 ospf 1 area0 *  使该接口加入到OSPFv3进程1并申明区域为0

R3(config-if)#exit

R3(config)#interface loopback1

R3(config-if)#ipv6 ospf 1 area0

R3(config-if)#exit

注意:在配置OSPFv3时,必须为路由器进程配置路由器ID(RID)这与OSPFv2完全不同,在OSPFv2的环境中,RID是一个可选项配置,但是在OSPFv3的环境中RID是必须配置,否则OSPFv3将无法启动。OSPFv3的RID将仍然以点分十进制的方法显示,比如:1.1.1.1这很像IPv4地址的表达方式。

在路由器R2的OSPFv3配置:

R2(config)#ipv6 router ospf 1

R2(config-rtr)#router

R2(config-rtr)#router-id2.2.2.2

R2(config)#interface e1/0

R2(config-if)#ipv6 ospf 1 area0

R2(config-if)#exit

R2(config)#interface loopback1

R2(config-if)#ipv6 ospf 1 area0

R2(config-if)#exit

在路由器R1的OSPFv3配置:

R1(config)#ipv6 router ospf 1

R1(config-rtr)#router-id1.1.1.1

R1(config-rtr)#exit

R1(config)#interface e1/0

R1(config-if)#ipv6 ospf 1 area 0

R1(config-if)#exit

R1(config)#interface loopback1

R1(config-if)#ipv6 ospf 1 area0

R1(config-if)#exit

第三步:现在可以检查OSPFv3邻居关系的状态、路由学习的情况,以及连通性检测。可以使用show ipv6 ospf neighbor来查看OSPFv3的邻居关系正常,如图12.124所示,并且可知路由器R3是DR路由器,R2是BDR路由器,关于为什么这样选举,在OSPFv2中有详细描述,这里不再重复描述。然后可以通过show ipv6 route查看路由器R1的IPv6路由表,如图12.125所示,可看出R1成功的学习到了路由器R2和R3公告出来的OSPF路由,其中的“O”就表示通过OSPFv3所学到的路由。最后在路由器R1上通过ping指令检测与路由器R2和R3上相关IPv6前缀的连通性,如图12.126所示,一切正常。

理解并配置:IPv6的OSPFv3

理解并配置:IPv6的OSPFv3

第四步:当完成上述配置后,可以通过协议分析器捕获并分析OSPFv3的协议报文,如图12.127所示为路由器R2发出的OSPFv3的协议报文。

理解并配置:IPv6的OSPFv3



更多相关文章
  • 理解并配置:IPv6的静态路由与默认路由
    理解并配置:IPv6的静态路由与默认路由不论是IPv4或者是IPv6的网络环境都完整的支持静态路由,静态路由是指由网络管理员手工配置的路由信息.当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息.静态路由信息在缺省情况下是私有的,不会传递给其他的路由器.建议: ...
  • 理解并配置:在路由器上建立主机名与DNS名称解析
    理解并配置:在路由器上建立主机名与DNS名称解析已建立技术群号:195228906 在网络管理时,对于IP地址的记忆永远是一件头痛的事情,特别是在大型网络中,所以通常会为网络中的设备做一个有标识性意义的命名,比如位于上海的路由器,就为它命名为"shanhai"然后将一个名称对应一 ...
  • 目前,IPv4面临枯竭的状态,IPv6正悄悄地走进我们的身边,所以对于我们IT专业人员掌握一点IPv6的基本配置是必要的.在路由器上配置:1.在路由器上接口配置IPv6地址:Router(config)#interface interface-numberRouter(config-if)#IPv6 ...
  • 深入理解及配置ISA Server 2006访问规则防火墙策略概述源主机和目标主机必须在于不同的网络ISA是严格按照顺序评估放火墙策略系统策略优先于防火墙策略访问规则是按照出站方向的主要连接端口来进行处理  匹配标准(元素)协议--出站方向从--源计划时间--到--目的网络用户--内容类型--图片 ...
  • 理解NetScaler配置中的NSIP,VIP,MIP,SNIP
    理解NetScaler配置中的NSIP,VIP,MIP,SNIPNetScaler的配置中经常会提到多种IP地址,例如NSIP.SNIP.MIP.VIP.这些IP应该如何理解和使用呢?在此大概说一下.NSIP:这个比较简单易懂,是NetScaler的管理IP,用于对NetScaler本身进行一般的系 ...
  • 理解和配置VLAN间的路由选择
  • IPv6悄然的来到了我们的身边,Windows 7已经开始支持IPv6,但是对于用户来说,Windows 7本来就还没弄明白,现在再加上一个IPv6本来就很晕的用户更加的摸不到头脑.下面就向大家介绍如何在Windows 7中配置IPv6 . 一.毛病初现: 由于局部学校出于日后晋级过渡简约而将自己的 ...
  • 配置方法非常简单就是在cmd模式下打netsh interface ipv6 install就安装上传说中的能我地球上每一里沙粒配置一个ip地址的IPv6啦.如何配置呢?在cmd下打netsh回车打interface ipv6回车add address 接口名称 ip地址.就是这么简单!!!
一周排行
  • Struts2教程4:使用validate方法验证数据<plug-in className="org.apache.struts.validator.ValidatorPlugIn"> ...
  • win8改win7最全教程包含可能遇到的所有问题
              今日,帮一个朋友的把她的系统从win8 优雅降级到了win7,大家都知 ...
  • linux下安装mplayer,新手轻松搞定(找不到包的,可以去我的博客下载)TEP 1. 下载必要的文件:下载主程序:MPlayer-1.0pre8.tar.bz2官方解码器:essential-20071007. ...
  • 你可能不知道的c++ 你可能不知道的 C++(一) 你可能不知道的 C++(二)
  • TMG2010发布web服务器
    准备DMZ区域的web服务器:1安装web服务器选择允许:所写的公用名称一定是公司索要发布 ...
  • 转自:http:[email protected][email protected]P与UDP的区别: 1.基于连接与无连接  2.对系统资源 ...
  • 两种双绞线的线序568A与568B
      两种在整个网络布线中应用一种布线方式,但两端都有RJ45端头的网络连线无论是采用端接方 ...
  • w(我)最近整理一些cisco的实验从简单到复杂,大家给指正那.....也许模拟器不同有的命令不一定和书上的一样,但是能达到同样的效果! VTP实验拓扑 首先设定在3560上配置两个vlan的IP地址VLAN100= ...
  • 首先让我们来看一个我朋友希望转换的纯文本文件的例子:Green for Mars!John R. DoeThe idea of little green men from Mars, long a staple of ...
  • 修改IntelliJ IDEA 7.0\bin下idea.exe.vmoptions     -server     -Xverify:none     -Xms300M     -Xmx512M     -XX:+ ...